PHP Singleton Mode

Server environment

1
2
3
4
5
$ cat /etc/issue
Ubuntu 16.04.2 LTS

$ php -v
PHP 7.0.22-0ubuntu0.16.04.1 (cli) ( NTS )

Composer Memory Limit

Server environment

1
2
3
4
5
$ cat /etc/issue
Ubuntu 16.04.1 LTS

$ php -v
PHP 7.0.30-0ubuntu0.16.04.1 (cli) ( NTS )

Install Supervisor For A PHP Script

Server environment

1
2
3
4
5
$ cat /etc/issue
Ubuntu 14.04.5 LTS

$ supervisord -v
3.0b2

Run PHP Script As Daemon Service

Server environment

1
2
3
4
5
$ cat /etc/issue
Ubuntu 14.04.5 LTS

$ php -v
PHP 5.6.32-1+ubuntu14.04.1+deb.sury.org+2 (cli)

How To Response Json in Symfony Logout Controller

Server Environment

1
2
3
4
5
6
7
8
9
$ cat /etc/issue
Ubuntu 16.04.2 LTS \n \l

$ cat composer.json
"require": {
"php": ">=5.5.9",
"symfony/symfony": "2.8.*",
...
},

JQuery-file-upload plugins work with Symfony3

My computer develop environment

1
2
3
4
5
6
7
8
9
10
11
12
13
14
Ubuntu 16.04.1 LTS

PHP 7.0.15-0ubuntu0.16.04.4 (cli) ( NTS )
Symfony Installer version 1.5.9
Composer version 1.3.2 2017-01-27 18:23:41

Symfony Installer version 1.5.9

mysql> select version();
+-----------+
| version() |
+-----------+
| 5.7.12 |
+-----------+

PHP Allow Multi Cross Domain Request

Server environment

1
2
3
4
5
$ cat /etc/issue
Ubuntu 14.04.5 LTS

$ php -v
PHP 5.6.32-1+ubuntu14.04.1+deb.sury.org+2 (cli)

PHP shared session

Server environment

1
2
3
4
5
$ cat /etc/issue
Ubuntu 14.04.5 LTS

$ php -v
PHP 5.6.32-1+ubuntu14.04.1+deb.sury.org+2 (cli)

About include and require in PHP

My computer develop environment

1
2
$ php -v
PHP 7.0.26

Pass parameters to PHP by shell commands

My computer develop environment

1
2
$ php -v
PHP 7.0.26

How PHP Connect to Mysql

My computer develop environment

1
2
$ php -v
PHP 7.0.26

Keep update Symfony3 tips

My computer develop environment

1
2
3
4
5
"require": {
"php": ">=5.5.9",
"symfony/symfony": "3.2.*",
...
}

Compile and install LAMP in Ubuntu

Server environment

1
2
$ cat /etc/issue
Ubuntu 14.04.5 LTS
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×